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Faster than your memory, more searchable than a stack of file folders, Microsoft® OneNote® 

2010 gives you one place to store all of your thoughts and information. Capture text, images, 

video and audio notes to keep all of your important content easily accessible. 

 Instantly search across all of your notebooks at once. OneNote even finds your search terms 

in images and audio. 

 Quickly consolidate content from multiple applications for easy access and organization.  

 Don’t lose your important information—OneNote automatically saves content as you add it 

to your notebooks. 

 Brainstorm and collaborate when and where you need to —simultaneously edit the same 

notebook with anyone you choose, even if they don’t have OneNote 2010 installed. 

Plan a pitch, a project, or your next vacation. Research a new car, a new market development, or 

a new topic for your term paper. Take meeting notes, class notes or recipe notes. Keep everyone 

up-to-date and key information at-hand, whether it’s for your clients, your team, or your favorite 

hobby.  

OneNote 2010: one easy, flexible, powerful space for all of your ideas. 



 

 

 

 2 
 

If you’re new to OneNote or would like to explore key features that may be new to you even if 

they’re not new to OneNote, read on. This section provides a brief introduction to some of the 

key features that make OneNote your own expandable, accessible resource center. Otherwise, 

jump ahead to the next section and explore what’s new in OneNote 2010. 

OneNote takes the concept of a digital notebook to a new level, giving you one easy-to-use, 

customizable, central source for capturing, organizing and accessing all of the information that 

you need to keep at hand.  

 Create multiple notebooks, and add as many sections, pages and subpages as you need in 

each notebook. You can have multiple notebooks open at once and even search all of your 

notebooks simultaneously. OneNote automatically saves and indexes content as you 

add it to a notebook, so the information you need is right at your fingertips. 

 Share notebooks with others and even take notes in the same notebook (even on the same 

page) simultaneously. When you store your notebooks to a shared location, you have an 

instant teamwork and brainstorming tool. 

 Customize OneNote notebooks and work the way you want. You can color-code pages and 

sections, drag-and-drop to rearrange pages and sections, and choose whether to use rule 

lines on pages as well as customize the width of rule lines. You can also just click to type or 

insert content anywhere on the page—above, below, or beside other notes.  

 Need more space on the page? Just click and drag to add space horizontally or vertically—

OneNote pages don’t run out of room, so it’s easy to keep related information together. 

You type notes while in a meeting or in class, when doing research, or when organizing your 

own thoughts. But text notes are far from the only type of information you need to store and 

access. Explore the many other types of content you can capture in OneNote for easy access 

whenever you need it. 



 

 

 

 3 
 

 Peel the sticky notes off of your monitor and desk and use OneNote side notes instead. You 

can quickly create a side note regardless of what program you’re working in and the notes 

you take are saved automatically in OneNote where you can file or search them later. 

 Insert screen clippings from your other open windows, such as to grab a screenshot of a 

news article that you need to reference for that paper you’re working on. OneNote inserts 

your screenshot on the page along with a date and time stamp showing when the shot was 

taken. If you take a screenshot from a Web page, OneNote also includes the Web address 

and page title automatically. 

 Send a copy of content from almost any program to OneNote using the Send to 

OneNote virtual printer. 

 Insert digital printouts of files, photos, and audio and video recordings. When you 

search for keywords, OneNote also searches the text in files you send to OneNote, digital 

printouts, screenshots, pictures inserted from your files, and the audio tracks in your audio 

and video files. 

 Record audio or video from within OneNote.1 When you record audio or video while 

taking notes—such as in a lecture, meeting, or presentation—OneNote adds an icon in the 

note margin. Click the icon beside any note later to play back what was being said or 

shown at the time you took that specific note. (Of course, always remember to get the 

permission of those present before you start recording!) 

 If you use a Tablet PC or other ink-enabled device, you can use OneNote like a traditional 

notebook and write with digital ink. OneNote learns your handwriting to make your ink 

notes searchable just like text and enables you to convert ink to text with just a click. 

Because OneNote automatically saves and indexes content as you add it to your notebooks, 

searching your notes is virtually instantaneous. OneNote also provides a host of features that 

make it easy for you to organize and access your information when and how you choose. For 

example: 

                                                 

1
 Available to computers that include or are connected to appropriate audio or video recording devices. 
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 Mark notes with Note Tags, such as To Do, Important, Question, or Idea. When you apply a 

tag, an icon appears next to the note. You can create or customize your own tags and search 

for tagged notes. You can even use tags interactively, such as by placing a checkmark in a To 

Do tag when the task is complete. 

 Create Microsoft Outlook® tasks from OneNote notes. Or insert Outlook calendar 

details into your notes to effortlessly keep meeting information together with the notes you 

take. 

See the Where to Find It section of this guide to learn how to access features discussed in this 

section. And if you’re ready to explore more of what OneNote 2010 can do, read on to learn 

about new and improved OneNote features—from the ability to access and share your 

notebooks on the Web to advancements in search, organization, customization tools and more. 
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When working with others, it’s important to stay on the same page. OneNote 2010 provides a 

better way to keep up with your team by giving you the power to create and collaborate 

seamlessly in near real-time. 

Redefine working together 

OneNote 2010 helps you break down barriers so you can share, brainstorm and get things done 

together, more efficiently and effectively. 

 Simultaneously edit shared notebooks with other people in different locations, whether or 

not they are connected to your personal or business computer network.2 

 Stay up to date effortlessly when sharing notebooks with others. When you open a shared 

notebook in OneNote 2010, see recent changes highlighted automatically along with 

author indicators showing who wrote what. You can also find changes by author to 

quickly see who made specific contributions. 

 You never have to worry about someone making a change to notes you need with the ability 

to restore previous Page Versions. You can also use the Notebook Recycle Bin to retrieve 

content that you inadvertently discarded. 

If your ideas and deadlines don’t always occur conveniently when you are at your desk, you are 

certainly not alone. Fortunately, OneNote 2010 gives you the power to get things done when 

and where you want. 

                                                 

2
 Simultaneous editing of shared notebooks with those outside of your network requires an appropriate device, Internet connection, 

and  either Microsoft SharePoint
®

 Foundation 2010 (for business) or a free Windows Live
TM

 ID (for personal use). The ability to use 

this functionality via Windows Live will become available in the second half of calendar year 2010. 
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Work when and where you choose 

It’s easy to take your notebooks with you and stay on top of your content on the go. 

 Microsoft OneNote Web App enables you to store your notes online and edit them from a 

Web browser. View, share and copy notes quickly and easily. You can even edit shared 

notebooks simultaneously with others who are using OneNote Web App or OneNote 2010.3 

 Microsoft OneNote Mobile 2010 gives you a lightweight editor for your notes that’s 

especially designed for easy use on your Windows phone.4 

Everyone has more to keep track of today. Whether you’re managing a business or your next 

home project, information comes in many forms and you want to stay on top of them all.  

OneNote 2010 keeps you easily connected to all of the important details. 

Find and organize your information 

It’s much easier to manage information when you can work the way you want. 

 Explore and organize your notebooks more effectively with an enhanced notebook 

navigation bar, improved tools for managing sections, and new multi-level page groups. 

 Save time with an advanced search experience that shows results as you type. OneNote 

2010 learns from your searches and prioritizes results to get you to the information you 

need quickly.  

 Add wiki links to pages, sections, and section groups within your notebook to ensure that 

related content is always easily accessible. 

                                                 

3
 Microsoft Office Web Apps require an appropriate device, Internet connection, supported Windows

®
 Internet Explorer

®
, Safari, or 

Firefox browser, and either SharePoint Foundation 2010 (for business) or a free Windows Live ID (for personal use). For Office Web 

Apps on Windows Live, OneNote Web App will become available in the second half of calendar year 2010. There are some 

differences between the features of Office Web Apps and the Office 2010 applications. 

4
 An appropriate device is required. Some mobile functionality requires an Internet connection. Office Mobile 2010 is not included in 

Office 2010 applications, suites, or Office Web Apps. It will be available at the final release of Microsoft Office 2010 on Windows 

phones (Windows Mobile 6.5 or above). There are some differences between the features of Office Mobile 2010 and the Office 2010 

applications. 
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 Apply new text styles for easy formatting to help structure your thoughts. And, use the 

Format Painter, newly available in OneNote, to keep your organization consistent by quickly 

copying formatting between pages, sections, and notebooks. 

Capture and file information with ease 

Easily capture and organize the content you need, from almost any source. 

 Take notes while working in Microsoft Word 2010, Microsoft PowerPoint® 2010 or 

Windows® Internet Explorer® using the new Linked Notes feature. OneNote provides a link 

to where you were in the source document at the time you took the note.  

 Send a copy of content from documents, Web pages, e-mail messages, or almost any 

program to the exact location you want in your OneNote notebooks using the new quick 

filing capability. 

Get easier access to the right tools, at the right time 

New and improved features can help you be more productive, but only if you can find them 

when you need them.  

The customizable Ribbon, new to OneNote 2010, makes it easy to uncover more commands so 

you can focus on your information, not how to get to it. And, the new Microsoft Office 

Backstage™ view helps you more easily print, share, and manage your notebooks, and 

customize your OneNote 2010 experience, all from one convenient location. 
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Redefine working together 

Shared notebooks enable you to edit the same notebook simultaneously with other people in 

different locations. OneNote 2010 provides several new and improved features that add power 

and flexibility to your shared notebooks so that you can brainstorm and collaborate more easily 

than ever. 

Shared Notebooks Improved! 

Now you can share notebooks with other people whether or not you share a common network 

location (such as a shared network drive or a shared folder on a home network). Just save your 

notebooks to a Microsoft SharePoint® Foundation 2010 site or a Windows Live™ SkyDrive folder 

and then access, share, and simultaneously edit them with others virtually anywhere.5  

Automatic Highlighting of Unread Changes New! 

When you open a shared notebook, recent changes made by other authors are automatically 

highlighted, so that you easily stay on top of what’s new. OneNote 2010 also adds the initials of 

the author who made each change so that you can quickly see who wrote what. Point to the 

author initials for a ScreenTip showing the author’s full user name and the time of the edit. 

Quick Tip: After you’ve reviewed recent changes, you can still quickly find changes you’d like review. On 

the Share tab, in the Shared Notebook group, click Recent Edits and then select a time period for which 

you want to browse changes (available time periods range from today to the past 6 months). You can also 

mark any text as unread for ease of review. To do this, just press CTRL+Q. Or, find this option on the 

Share tab, in the Unread group, under the Mark as Read options. 

                                                 

5
 Simultaneous editing (also referred to as co-authoring) of shared notebooks with those outside of your network requires an 

appropriate device, Internet connection, and either SharePoint Foundation 2010 (for business) or a free Windows Live ID (for 

personal use). Co-authoring via Windows Live will become available in the second half of calendar year 2010. 
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Figure 1: When you open a shared notebook, you automatically see new changes highlighted 

along with initials of the author who made the change. 

Show/Hide Authors and Find by Author New! 

When you work in a shared notebook, OneNote 2010 automatically shows you author initials 

where others have made changes, so that you automatically see who made each contribution.  

You can also find all edits by author for the active notebook, the active section, or all of your 

open shared notebooks, as shown in Figure 2. 

 

Figure 2: Instantly see who made changes to the active page. Or, quickly find all edits by the 

author who made them. 

Quick Tip: Author initials remain on shared notebook pages for easy reference. If you prefer to work 

without author initials visible, on the Share tab, click Hide Authors. 
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Page Versions New! 

Share notebooks with confidence, knowing that you don’t have to worry about others making 

changes to notes you need. OneNote preserves earlier versions of each page as different people 

make changes. So, if someone changes content inadvertently, you can view the change history 

and restore a previous version with just a couple of clicks. 

 

Figure 3: Previous page versions are identified by an information bar at the top of the page. 

The date of each version and the name of the person who made the changes appear on the 

page tab for each previous version. 

Quick Tip: Right-click a page tab for quick access to the Show Page Versions command. The menu 

available from the Page Versions button on the Share tab also gives you the options to quickly delete all 

previous page versions for the active section, section group, or notebook. You can also disable history for 

a given notebook so that previous page versions are not saved. 
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Notebook Recycle Bin New! 

Did you or another author discard a page that you still want to use? Perhaps you deleted an 

entire section only to remember that it included content you need. OneNote 2010 makes it easy 

to change your mind or to get back content that other editors delete. 

A Notebook Recycle Bin is available for each of your notebooks and stores deleted pages and 

sections for 60 days. 

Quick Tip: The menu available from the Notebook Recycle Bin command on the Share tab gives you 

the option to empty the recycle bin as well as to disable history for the active notebook. When you 

disable history from either this location or the Page Versions menu noted earlier, both versions and 

recycle bin are disabled. 

IRM Protection Improved! 

When you need to include information in shared notebook content that should not be 

accessible to everyone, use Information Rights Management (IRM) protection to limit access to 

sensitive content. OneNote 2010 makes it easy by giving you the ability to insert IRM-protected 

XPS documents into your notebooks as printouts. 

Quick Tip: When you create an XPS version of an IRM-protected document in any Office 2010 program, 

IRM protection settings are retained by default. To change this setting, in the Publish as PDF or XPS 

Document dialog box, click Options. To insert your IRM-protected XPS document into OneNote as a 

printout, on the Insert tab, in the Files group, click File Printout. 
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Work when and where you choose 

OneNote Web App New! 

When you want to leave your computer behind or need easy, shareable tools for collaborating 

with others, do you have what you need to get things done easily and effectively? Now you do. 

Save your OneNote notebooks online and then access, edit, and share them from virtually any 

computer with an Internet connection.6 

 

Figure 4: Collaborate with virtually anyone, anywhere using OneNote Web App. 

                                                 

6
 Requires an appropriate device, Internet connection, supported Internet Explorer, Safari, or Firefox browser, and either SharePoint 

Foundation 2010 (for business) or a free Windows Live account (for personal use). For Office Web Apps on Windows Live, OneNote 

Web App will become available in the second half of calendar year 2010. There are some differences between the features of Office 

Web Apps and the Office 2010 applications. 
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 Simultaneously edit the same shared notebook with others who are using OneNote Web 

App or OneNote 2010. 

 Create new pages and sections and use other familiar features that you know from 

OneNote, including AutoCorrect, spell-checking as you type, font and paragraph 

formatting, text styles, tags, and more. 

 See who authored specific content in a shared notebook and access previous page 

versions. 

 Insert pictures, tables, and even Office.com ClipArt. 

Office Web Apps—including OneNote Web App, Microsoft Excel® Web App, Microsoft 

PowerPoint® Web App, and Microsoft Word Web App—give you flexible access, a familiar 

editing environment, and a selection of features that you already know to help you get your 

work done on your terms.  

Quick Tip: OneNote Web App makes it easy to share files with people who work on earlier versions of 

Microsoft Office for Windows or Mac, or even with those who don’t have Microsoft Office on their 

computer. 

OneNote Mobile 2010  

Sometimes you’ve got to work when you’re moving between point A and point B. Fortunately, 

OneNote Mobile 2010 enables you to easily take action while you’re on the road. 7 

 Make a quick list, insert voice clips or pictures. You can even capture pictures in your 

notes on the go with your camera phone. 

 Enjoy a familiar experience when creating or editing notes on your mobile device. Use 

AutoCorrect and essential authoring capabilities, such as bullets, numbering, and font 

formatting. 

                                                 

7
 Office Mobile 2010 includes OneNote Mobile 2010 as well as Word Mobile 2010, Excel Mobile 2010, PowerPoint Mobile 2010 and 

SharePoint Workspace Mobile 2010. Outlook Mobile 2010 comes pre-installed on Windows phones and is the default e-mail client. 

Office Mobile 2010 is not included in Office 2010 applications, suites, or Office Web Apps. It will be available at the final release of 

Microsoft Office 2010 on Windows phones (Windows Mobile 6.5 or above). There are some differences between the features of 

Office Web Apps and the Office 2010 applications. 
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 View rich graphics captured in your notes full screen. Easily pan and zoom or export the 

image for use in other applications. 

 

Figure 5: Stay connected to 

your notes from wherever you 

need to be with OneNote 

Mobile 2010. 

Quick Tip: Keep organized and in sync. Synchronize your notes with OneNote 2010 on your PC using the 

Windows Mobile Device Center, available on Windows 7.
8
 

                                                 

8
 Windows Mobile Device Center is compatible with Windows 7 and Windows Vista

®
. 
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Find and organize your information 

Notebook Organization Tools New and Improved! 

Get to your information more easily and organize it just as you like it. OneNote 2010 provides a 

streamlined, flexible work environment that gives you more options to get things done the way 

you want. 

 New and improved, more flexible page tabs that you see in Figure 6 give you two levels 

of subpages, enable you to drag-and-drop to create subpages, display subpage names 

indented from left for ease of organization, and provide an in-place New Page icon that 

appears wherever you point so that you can create pages exactly where you need them. 

 

Figure 6: More flexible page 

tabs give you exactly the 

organization you need 

without extra steps. 

Quick Tip: OneNote 2010 also makes it easier to edit notes regardless of how much screen real estate 

you have. When you have a note page with a single container in a narrow window (such as when using 

the new Dock to Desktop feature discussed later in this guide), your text now automatically wraps within 

your view. 

 Improved notebook navigation provides handles that enable you to see and access all 

of your notebooks or all of the sections in a notebook with ease. 
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Figure 7: Navigation improvements give you easy, instant access to all of your open notebook 

sections. 

 Improved tools for managing sections enable you to copy or merge one section into 

another. 

 

Figure 8: Right-click a section tab for new options to copy or merge sections. 

Search Experience Improved! 

OneNote 2010 makes a great search experience even better by showing you search results as 

you type. Search now also remembers your past choices to save you time by automatically 

prioritizing search results. 

Search all notebooks at once or search within individual pages, sections or notebooks. OneNote 

searches your text as well as the text within images in your notes. OneNote 2010 can even 

search audio for your keywords in the audio and video recordings that you include in your 

notebooks. 
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Figure 9: View prioritized search results as you type. 

Quick Tips:  

 Keyboard users, utilize search to quickly access whatever notes you need. Just type CTRL+E to begin a 

search and then type a few characters to match the page you want. Use the arrow keys to move up or 

down in the search results list and then press ENTER to select the page you want. Because OneNote 

learns from past choices, these keyboard commands can quickly become shortcuts to the pages you 

need most often.  

 OneNote 2010 now supports 64-bit optical character recognition (OCR). So, whether you work on a 

32-bit or 64-bit PC, OneNote 2010 can search within the text of images that you include in your 

notebooks. 
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Wiki Linking New! 

Quickly generate and customize links to new content in your notebooks so that everyone using 

the same notebook is automatically pointed to the right place. With wiki linking, you can easily 

reference and browse through related content such as note pages, sections and section groups 

within a notebook.  

 

Figure 10: The new Pick 

a location in OneNote 

option in the Link dialog 

box gives you easy 

access for creating your 

own wiki within your 

OneNote notebooks. 

Quick Tips:  

 Right-click a paragraph, page tab, section tab or notebook for the option to copy a link to that 

location. You can then use any paste method (such as CTRL+V) to paste the link on the page where 

you are creating your wiki links. Right-click the pasted link for the option to Edit Link where you can 

easily customize the text to display, as shown in Figure 10. 

 To quickly create a wiki link right on the page, type the name of a page, section, or notebook inside 

double brackets. Your text automatically converts to a link. If the name you type is not recognized, 

OneNote creates a new page with that name in the active section. 
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Text Formatting Tools New! 

A little bit of formatting can go a long way to helping you structure and organize information. 

Now, formatting your notes is easier than ever with new text styles that you can apply with just a 

click. You can even use many of the same shortcut keys that you know from Microsoft Word for 

applying styles to your text. 

 

Figure 11: Quickly apply styles and formatting to text in your notebooks. 

Quick Tips:  

 Apply styles from the Home tab, as shown in Figure 11. Or use keyboard shortcuts CTRL+ALT+1, 2, or 

3 to apply Heading styles 1-3 and CTRL+SHIFT+N to apply Normal style. 

 Formatting lists is now faster and simpler as well. When you start a bulleted or numbered list in 

OneNote 2010, the first level of your list is automatically indented. 

 Whatever type of formatting you apply to text in OneNote 2010, you can now use the Format Painter 

that you know from other Microsoft Office programs to easily reuse that formatting for consistent 

organization across your notebooks. Access the Format Painter on the Home tab, in the Clipboard 

group, as shown in Figure 11. 



 

 

 

 20 
 

Capture and file information with ease 

Linked Notes New! 

You take notes or gather data while working on a document or presentation, or while doing 

research on the Web. But, how do you keep all of the pieces connected and find the information 

you need when you need it? 

OneNote 2010 makes it easy by creating links not just to the file you’re working on while you 

take notes, but to where you were in that file when you took a given note. Dock OneNote on the 

side of your desktop and take notes while you work on a Word 2010 document or PowerPoint 

2010 presentation, or while browsing Web pages in Internet Explorer. As you see in Figure 12, 

OneNote adds an icon in the margin beside your notes. Just click that icon when reviewing your 

notes later to open the source file and jump straight to the paragraph, slide, or Web page that 

was active when you took the note. 

 

Figure 12: The OneNote Linked Notes feature adds an icon in the margin of each paragraph 

as you take notes in the OneNote window docked on the side of your screen, indicating the 

source program and providing a link to your location in the source file. 
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Quick Tips: 

 You can enable OneNote Linked Notes from the Review tab in Word 2010 or PowerPoint 2010, or 

from the Tools menu in Internet Explorer 6 or later.  

 Linked Notes is available when working in OneNote 2010 notebooks, and is enabled in Word and 

PowerPoint for previously saved Microsoft Office 2010 documents or presentations.  

 If you need to share Linked Notes with others—such as when sending notes by e-mail—and you don’t 

want to include links, you can quickly remove all links from Linked Notes in the active notebook. To 

do this, click the File tab to open Backstage view, click Options, and then click Advanced. Under the 

heading Linked Notes, find the option Remove Links from Linked Notes. 

 Need to take notes while working in other programs? On the View tab, click Dock to Desktop to 

keep OneNote 2010 docked on the right side of your screen while you work in any program. Notes 

automatically begin linking if you’re working in a supported file type for Linked Notes as indicated 

above. But, regardless of the program you’re using, you can always keep OneNote easily accessible. 

Quick Filing New! 

You’re working on a project that has several components—documents, Web pages, graphics 

files, you name it—and you need an easy way to collect and organize information that you 

capture in all of those programs. Or, maybe you just bought something online and need to grab 

a copy of the confirmation page. 

Whatever the information you need to save, the new quick filing capability in OneNote 2010 

makes it easy to get that content to the right place without extra work. When you take a screen 

clipping from OneNote 2010, send an Outlook 2010 e-mail message to OneNote, start a linked 

note-taking session or print a document to the Send to OneNote 2010 virtual printer, you get a 

dialog box from which to select the exact location in your OneNote notebooks to place that 

content. 
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Figure 13: Save time 

by using quick filing to 

select a location as 

you send content to 

OneNote, take a 

screen clipping or 

begin taking Linked 

Notes. 

Quick Tip: People using both 32-bit and 64-bit PCs can now use the Send to OneNote printer. OneNote 

2010 includes a 64-bit printer driver for the Send to OneNote 2010 virtual printer. 

Get easier access to the right tools, at the right time 

Ribbon New! 

Locate the commands you need when you want them and where you want them. The 

customizable Ribbon, new to OneNote 2010, is available in all Office 2010 applications. The 

Ribbon replaces traditional menus and toolbars to give you a more personalized work 

experience. It’s designed to help you more easily find and use the full range of features that 

OneNote provides—so that you can get more done in less time. 

 Create your own tabs or customize built-in tabs on the Ribbon to personalize the 

OneNote 2010 experience to your work style.  

 The standard tabs that you see on the Ribbon are organized to display commands 

relevant to a given task, so that you can find what you need more quickly.  
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 The Ribbon also provides contextual tabs to give you exactly the tools you need, just 

when you need them. For example, when you click in a table, a Table Tools Layout tab 

appears to provide all the tools you need for working with that table. 

 

Figure 14: The customizable Ribbon in OneNote 2010 helps you get to the features you need 

more quickly. 

Microsoft Office Backstage View New! 

On the left edge of the Ribbon you see the File tab. Just click that tab for an all-access pass that 

makes it easier than ever to customize your OneNote 2010 experience. 

The new Backstage view replaces the traditional File menu to provide a single location for 

managing your notebooks as well as sharing, printing, and publishing your notes. For example, 

when you first open Backstage view, you’re on the Info tab shown in Figure 15. From this one 

location, you can manage settings and properties for all of your open notebooks, share a 

notebook, and manage notebook syncing. 

 

Figure 15: 

The new 

Backstage 

view gives 

you a single, 

convenient 

location for 

all of your 

notebook 

management 

tasks. 
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Translation Tools New and Improved! 

OneNote 2010 makes it easier than ever to communicate across multiple languages. Get easy 

access to translation tools from the Review tab in OneNote 2010. Translated selected text or use 

the new Mini Translator for on-the-spot translations as you work. 

 

Figure 16: Enable 

the Mini Translator 

from the translation 

options on the 

Review tab.  

Quick Tip: English assistance and Windows English text-to-speech playback (along with additional text-

to-speech languages for download) are available from the toolbar at the bottom of the Mini Translator, 

shown in Figure 16.
9
 

Language Tools Improved! 

If you’re one of the many people who work across multiple languages, you now have more 

flexibility to work as you choose. Simplify and customize your multilingual experience with 

separate language settings for editing, Help, display, and ScreenTips. 

Quick Tips: 

 If you add a language for which proofing tools or keyboard layout are not installed, you see 

notification with links to help you easily correct the issue, as shown in Figure 17. 

 Access language preferences in the OneNote Options dialog box from the Review tab, in the 

Language group, or from Backstage view. 

 When you set your language preferences in OneNote 2010, you set them for all applicable Office 

2010 programs, including Microsoft Word, Excel
®

, PowerPoint, Outlook, Publisher, and (excluding 

ScreenTip settings) Access
®

 and SharePoint
®

 Workspace. 

                                                 

9
 Additional text-to-speech languages are free and available to download from the Microsoft Download Center: 

http://www.microsoft.com/download. 
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Figure 17: Easily 

set separate 

editing, Help, 

display, and 

ScreenTip 

languages. 

Equation Tools New! 

Whether you’re taking trigonometry this semester or you’re a professional engineer, use new 

equation tools to easily create and display equations in your notes. Select from several pre-

created equation types to help you get started—from a basic theorem (such as         ) to 

more complex mathematical constructs as shown in Figure 18—or create your own equation 

from scratch with the rich set of intuitive tools available on the Equation Tools Design tab. 

 

Figure 18: Use 

a powerful set 

of equation 

editing tools to 

craft whatever 

math you 

need. 

Quick Tip: If your computer runs Windows 7 and you use an ink device, such as a Tablet PC, you can also 

write math in your notes and convert it to an equation using the Ink to Math command on the Draw tab. 
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Features and Benefits Where to Find 

Create a notebook  Click the File tab to open Backstage view and then click New. 

Create a section  Click the Create a New Section icon that appears at the end 

of the section tab set for the active notebook, as shown here. 

 

Create a page  Click the New Page command that appears at the top of the 

page tabs in the active section or press CTRL+N. Or, use the 

new in-place new page icon that’s new to OneNote 2010.  

Note: The text you add in the title area that appears at the top of the 

page automatically becomes the page tab name. 

Create a subpage  Just drag the name that appears on the page tab to the right 

to turn a page into a subpage. OneNote 2010 has two levels of 

subpages. 

Note: You can also right-click a page tab for the option to promote, 

demote, or collapse subpages. 

Search  Find the search box to the far right of the section tabs that 

appear at the top of the note page window. Click the 

dropdown arrow in the search box to select the search scope 

(ranging from the current page to all notebooks). 

Share a notebook  Notebooks saved to a shared location are automatically shared 

with those who have access to the location. You can 

simultaneously edit shared notebooks with anyone who has 

access to that notebook. 

 To share a notebook that is not currently in a shared location, 

click the File tab to open Backstage view and then click Share. 
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Features and Benefits Where to Find 

Rearrange sections or pages  Just drag a section tab to move it within the current notebook 

or drag a page tab to move it within the current section.  

 To rearrange sections or pages outside of the current scope, 

right-click the section tab or page tab and then click Move or 

Copy. 

Change section color  Right-click a section tab for several section-management tools, 

including Section Color. 

Note: Section and page colors do not print. 

Change page color  On the View tab, in the Page Setup group, click Page Color.  

Add or customize rule lines  On the View tab, in the Page Setup group, click Rule Lines to 

access rule line options. 

Add space to a page  On the Insert tab, in the Insert group, click Insert Space. 

When you move your insertion point over the page, you see a 

line showing where the new space will begin. When the line is 

positioned where you want the new space to begin, click and 

then drag to create the desired space. 

Note: When your insertion point is near the right or left edge of the page, 

you see a vertical line for adding space on the left or right side of the 

page. Otherwise, when your insertion point is over the page you see a 

horizontal line for adding space above or below the insertion point. 

Create a side note  By default, when you click the OneNote icon in the Windows 

system tray, a new side note opens. Right-click the OneNote 

icon in the system tray for side note options. 

Insert a screen clipping  From within OneNote, on the Insert tab, in the Images group, 

click Screen Clipping.  

 When the OneNote icon appears in the Windows system tray, 

you can create a OneNote screen clipping from any open 

window by pressing the Windows key+S. 



 

 

 

 28 
 

Features and Benefits Where to Find 

Send content to OneNote  To send a copy of content from virtually any application to 

OneNote, print that content to the Send to OneNote 2010 

virtual printer. Just select Send to OneNote 2010 as the 

printer in your application’s print interface. 

Insert a file printout  From within OneNote, on the Insert tab, in the Files group, 

click File Printout.  

Insert a picture  From within OneNote, on the Insert tab, in the Images group, 

click Picture.  

Insert audio or video  To insert an existing audio or video object on the page, on the 

Insert tab, in the Files group, click Attach File. 

Record audio or video  On the Insert tab, in the Recording group, click Record 

Audio or Record Video. 

Use contextual audio or 

video notes 

 When you record audio or video while taking notes, OneNote 

adds an icon beside each paragraph that you can click to 

playback what was being recorded at the time you took the 

specific note. 

Use note tags  On the Home tab, in the Tags group, expand the Tags gallery 

to select a tag or for the option to customize tags. Or, in the 

Tags group, click Find Tags to search for tags in your 

notebooks. 

Create an Outlook task  On the Home tab, in the Outlook group, click Outlook Tasks. 

Insert Outlook meeting 

details 

 On the Home tab, in the Outlook group, click Meeting 

Details. 
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 Features and Benefits Where to Find 

Improved! Shared notebooks  To create a shared notebook, on the Share 

tab of the Ribbon, in the Shared Notebook 

group, click New Shared Notebook. 

Note: To share an existing notebook, click the File tab 

to open Backstage view. Then, click the Share tab for 

the option to save your notebook to a shared location. 

New! See what’s new  When you open a shared notebook, newly 

added content is automatically highlighted 

along with author initials showing who wrote 

what. 

Note: Point to author initials to see the author’s full 

user name and the date and time of the change. 

New! Find by Author  On the Share tab, in the Shared Notebook 

group, use the Hide Authors and Find by 

Author commands. 

New! Page versions  On the Share tab, in the History group, click 

Page Versions. 

New! Notebook Recycle Bin  On the Share tab, in the History group, click 

Notebook Recycle Bin. 

Improved! IRM protection  On the Insert tab, in the Files group, click 

File Printout and select an IRM protected 

XPS document. 
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 Features and Benefits Where to Find 

New! Access your notebooks 

on the Web  

  

 Visit http://office.com/web-apps for 

information on how to get started with Office 

Web Apps 

Improved! OneNote Mobile 2010  Office Mobile 2010 is not included in Office 

2010 applications, suites, or Web Apps. It will 

be available concurrently with the final 

release of Office 2010. 

 Features and Benefits Where to Find 

Improved! Page tabs  By default, find page tabs on the right of the 

screen, below the Search box. 

Improved! Notebook navigation 

bar 

 Find the notebook navigation bar on the left 

of the screen, below the Ribbon. 

Improved! Search navigation  In the Search box (found on the right of the 

screen below the Ribbon), begin to type a 

search term. An expanded search navigation 

pane appears as you type, displaying results 

in your recent locations, text in titles, and text 

in body. 

New! Wiki linking  On the Insert tab, in the Links group, click 

Link. 

Note: To quickly create a wiki link on a OneNote 2010 

page, type the name of the OneNote location to which 

you want to link surrounded by double brackets (i.e., 

[[name]]). The text automatically converts to a link 

when the page, section, or notebook name is 

recognized. 

http://office.com/web-apps
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 Features and Benefits Where to Find 

New! Apply styles to your text   Find the Styles group on the Home tab.  

 Or, use familiar keyboard shortcut keys 

including CTRL+ALT+1,2,3 to apply Heading 

styles and CTRL+SHIFT+N to apply Normal 

style. 

New! Format Painter  On the Home tab, in the Clipboard group, 

click Format Painter.  

Note: To paste the same formatting to multiple 

locations without reselecting Format Painter, 

double-click the Format Painter command. 

New! Dock to Desktop  On the View tab, in the Views group, click 

Dock to Desktop. 

New! Linked Notes  On the Review tab, in the Notes group, click 

Linked Notes.  

 Then, open a saved Word 2010 document, 

PowerPoint 2010 presentation, or a Web 

page in Internet Explorer 6 or later, and take 

notes as you work.  

Note: An icon representing the application you're 

working in appears beside your OneNote notes. Click 

that icon to open the source document.  

New! Quick filing  When you begin a linked note-taking session, 

create a screen clipping from within 

OneNote, send an e-mail message from 

Outlook 2010 to OneNote, or print content 

from another program to the Send to 

OneNote 2010 virtual printer, the Select 

Location in OneNote dialog box opens in 

OneNote so that you can specify where to 

place your printout. 
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 Features and Benefits Where to Find 

New! Ribbon  The Ribbon replaces the menus and toolbars 

found at the top of the screen. 

 To customize the Ribbon, in Backstage view, 

click Options and then click Customize 

Ribbon. 

New! Backstage view  Click the File tab on the Ribbon to open 

Backstage view. 

Improved! Language tools  On the Review tab, in the Language group, 

click Language and then click Language 

Preferences. 

Note: Changing these settings from any application 

changes them for all applicable Office 2010 

applications. 

New and 

Improved! 

Translation tools  On the Review tab, in the Language group, 

click Translate. 

New! Math equation support  On the Insert tab, in the Symbols group, 

click Equation.  

Note: You can also convert ink to a math equation and 

then use the same rich equation tools for editing. On 

the Draw tab, in the Convert group, click Ink to 

Math. 
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 Feature\Benefit Included   Improved  New 

Redefine working together 

 2003 2007 2010 

Shared notebooks 

Working with others in a shared notebook is now 

even easier and more flexible with automatic 

highlighting of unread changes, related features 

such as Find by Author, and more. Additionally, 

when you store your shared notebook online, 

you can simultaneously edit that notebook with 

others using both OneNote 2010 and OneNote 

Web App. 

   

Automatic highlighting of changes 

Content added since you last opened a shared 

notebook is automatically highlighted along with 

author initials to show who wrote what.  

   

Find by author 

Instantly see who added new information in a 

shared notebook. 

   

Page Versions 

Access previous versions of pages in your shared 

notebooks. 

   
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 2003 2007 2010 

Notebook Recycle Bin 

Review and restore previously deleted pages. 
   

IRM protection 

Insert IRM protected XPS documents as printouts 

in your notebook to ensure that only the right 

people view sensitive information. In OneNote 

2007, IRM protected XPS documents could be 

inserted as embedded objects. 

   

Work when and where you choose 

 2003 2007 2010 

OneNote Web App 

View and do lightweight editing of OneNote 

notebooks from virtually any computer with a 

Web browser. Simultaneously edit notebooks 

with other people who are using either OneNote 

Web App or OneNote 2010. 

   
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Find and organize your information 

 2003 2007 2010 

Notebook navigation bar 

Improved navigation gives you instant access to 

all of your open notebooks or all sections in your 

active notebook. 

   

Sections 

Copy sections between your notebooks and 

merge sections together for easier notebook 

management. 

   

Page tabs 

Create multi-level subpages, collapse subpages, 

and even drag and drop to create subpages. 

Additionally, a floating New Page icon enables 

you to create a new page exactly where you want 

it. 

   

Search navigation 

Get to your information faster with search results 

as you type, prioritized based on your past 

choices. 

   

Wiki linking 

Generate links to OneNote content so everyone 

using the same notebook is automatically 

pointed to the right place. 

   
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 2003 2007 2010 

Styles 

Apply text styles to easily help structure and 

organize your thoughts. 

   

Format Painter 

Quickly copy the formatting of selected text to 

easily apply the same formatting elsewhere in 

your notebooks. 

   

Lists 

When you start a bulleted or numbered list, the 

first level of bullets is now automatically 

indented. 

   

Capture and file information with ease 

 2003 2007 2010 

Linked Notes 

Take notes while working in a Word 2010 

document, a PowerPoint 2010 presentation, or in 

Internet Explorer 6 or later, and notes link 

automatically to the active location in the source 

file. 

   

Dock to Desktop 

Dock OneNote to your desktop to easily take 

notes while working in other applications. 

   
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 2003 2007 2010 

Quick Filing 

Pick a location in your notebook to place your 

notes as you insert them from multiple sources, 

including documents, Web pages and e-mail 

messages, and when using Linked Notes. 

   

Get easier access to the right tools, at the right time 

 2003 2007 2010 

Ribbon 

The Ribbon is designed to help you find the 

features you need fast. You can also customize 

the Ribbon to meet your personal work style. 

   

Backstage View 

Backstage view replaces the traditional File menu 

to let you share, print, and publish your notes 

with just a few clicks. 

   

Translation tools 

Use on-demand translation and a Mini Translator 

to easily work across languages.  

   

Language tools 

Access a single dialog box in OneNote 2010 to 

set preferences for editing, display, ScreenTip, 

and Help languages. 

   

Math equation support 

Create and display math equations in your notes, 

using a rich set of equation editing tools. 

   
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About Microsoft OneNote 2010 

1. What is OneNote 2010? 

2. How can I use OneNote 2010? 

3. What are some of the major updates to OneNote 2010 from earlier versions? 

4. Where can I get more information about OneNote 2010? 

OneNote 2010 System Requirements & Compatibility 

1. Are there special system requirements for running OneNote 2010? 

2. Can I open previous versions of Microsoft OneNote notebooks in OneNote 2010?  

3. Can I open OneNote 2010 notebooks using previous versions of Microsoft OneNote? 

4. Do I need other products in order to use OneNote 2010 features? 

5. Which browsers are supported for the new OneNote Web App? 

Using OneNote 2010 

1. Are there free OneNote 2010 resources and training available from Microsoft? 

2. Can I customize OneNote 2010 based on how I use the product? 

3. Can I access my notebooks when I am away from my primary computer? 

4. How do I access OneNote 2010 notebooks from a Web browser? 

5. What can I do with my OneNote 2010 notebooks in OneNote Web App? 

6. What can I do with my OneNote 2010 notebooks in OneNote Mobile 2010? 

Buying OneNote 2010 

1. Which editions of Microsoft Office 2010 will include OneNote 2010? 

2. Will OneNote 2010 be available for standalone purchase? 

3. Can I try OneNote 2010 before I buy it? 

4. Is there a Macintosh version of OneNote 2010? 

5. Is there a cost for using OneNote Web App? 

6. When will Office Mobile 2010 be available and how do I get it? 

OneNote 2010 Shared Notebooks 

1. What is a shared notebook? 

2. Do I need to be on the same computer network with other editors to share notebooks in 

OneNote 2010? 

3. Which Office 2010 applications enable co-authoring? 
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1. What is OneNote2010? 

OneNote 2010 is your go-to source for brainstorming, organizing, and storing all of your 

thoughts and ideas. A powerful, flexible digital notebook, OneNote 2010 automatically saves 

the information you add to your notebooks—typed, written, audio, video, and images—and 

gives you powerful, intuitive tools for accessing exactly the content you need when you need 

it. Additionally, OneNote 2010 helps you collaborate and brainstorm more easily with others 

by giving you the power to simultaneously edit shared notebooks with others virtually 

anywhere and anytime. 

2. How can I use OneNote 2010? 

Use OneNote 2010 to store and manage all of the information you need to access easily. 

Whether you’re simply taking notes in a meeting or planning a major project, lose the legal 

pad and take advantage of tools that turn your notebook into a digital resource center. For 

example, take notes while working on a document and your notes automatically link to the 

relevant portion of the document; search keywords across all of your notebooks and access 

them immediately, whether they appear in text, pictures, audio, or video. You can also use 

OneNote 2010 to work more easily with other people than you might imagine, by seamlessly 

editing the same notebook at the same time as others who are working on their computers 

or on the Web. 

3. What are some of the major updates to OneNote 2010 from earlier versions? 

Explore some of the top reasons to upgrade to OneNote 2010. 

4. Where can I get more information about OneNote 2010? 

A good place to start for more information about OneNote 2010 is the OneNote Guide 

notebook that is automatically available when you open OneNote 2010. Additionally, you 

can learn more through a variety of online resources including blogs from members of the 

OneNote 2010 product team and the OneNote Community. For example, explore Nota Bene: 

The OneNote Blog, Daniel Escapa’s OneNote Blog, and the I  OneNote Community. 

http://blogs.msdn.com/michael_oldenburg/
http://blogs.msdn.com/michael_oldenburg/
http://blogs.msdn.com/descapa/
http://iheartonenote.com/#meteor=PymBtylC6qV
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1. Are there special system requirements for running OneNote 2010? 

Office 2010 was built to maximize performance across the hardware you already own, while 

also positioning you for future hardware innovations such as 64-bit chips, advanced graphics 

cards, multi-core processors and alternative form factor devices. 

Following are minimum system requirements for Microsoft Office Professional Plus 2010: 

Processor 500 MHz processor; 1 GHz required for Outlook with Business Contact Manager 

Memory 256 MB RAM; 512 MB recommended for graphics features, Outlook Instant Search, 

Outlook with Business Contact Manager, and certain advanced functionality. 

Hard disk 3.0 GB available disk space 

Display 1024x768 or higher resolution monitor 

Operating system Windows XP with Service Pack (SP) 3 (32-bit operating system (OS) only) or Windows 

Vista® with SP1, Windows 7, Windows Server® 2003 R2 with MSXML 6.0, Windows Server 

2008, or later 32- or 64-bit OS. 

Graphics Graphics hardware acceleration requires a DirectX® 9.0c graphics card with 64 MB or more 

video memory. 

Additional Notes  Certain advanced functionality requires connectivity to Microsoft Exchange Server 

2010, Microsoft SharePoint Server 2010, Microsoft Office Communications Server 2007 

R2, and/or Microsoft SharePoint Foundation 2010. 

 Certain features require Windows Search 4.0. 

 Internet functionality requires an Internet connection. 

 Certain online functionality requires a Windows Live ID. 

 Certain features require Internet Explorer (IE) 6 or later, 32-bit browser only.  

 Viewing a PowerPoint presentation broadcast requires one of the following browsers: 

Internet Explorer 7 or later for Windows, Safari 4 or later for Mac, or Firefox 3.5 or later 

for Windows, Mac or Linux. 

 Certain OneNote features require Windows Desktop Search 3.0, Windows Media® 

Player 9, Microsoft ActiveSync® 4.1, microphone, audio output device, video 

recording device, TWAIN-compatible digital camera, or scanner. Send to OneNote 

Print Driver and Integration with Business Connectivity Services require Microsoft .NET 

Framework 3.5 and/or Windows XPS features. 

 Product functionality and graphics may vary based on your system configuration. 

Some features may require additional or advanced hardware or server connectivity; 

visit http://www.office.com/products. 

To obtain system requirements for all Microsoft Office 2010 suites and standalone 

applications, visit Office.com. 

http://www.office.com/products
http://office.com/
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2. Can I open previous versions of OneNote notebooks in OneNote 2010? 

Yes, you can open notebooks created with OneNote 2003 or OneNote 2007 in OneNote 

2010. When you open a notebook that was created using OneNote 2003, a prompt appears 

at the top of the page to upgrade the notebook to OneNote 2010 format before the 

notebook can be edited. 

3. Can I open OneNote 2010 notebooks using previous versions of OneNote? 

To open OneNote 2010 sections or pages in OneNote 2007, save the file as a OneNote 2007 

section. To do this, click the File menu to open Backstage view. Click Save As and then click 

either Page or Section to see the option to save as a OneNote 2007 section.  

4. Do I need other products in order to use OneNote 2010 features? 

None of the features for creating and editing notebooks in OneNote 2010 require other 

products. However, some features do work with other Office 2010 applications and 

additional requirements exist for extending the capabilities of shared notebooks beyond 

your computer network: 

 To simultaneously edit a shared notebook with others who are using OneNote Web App, 

either SharePoint Foundation 2010 (for business) or a free Windows Live ID (for personal 

use) is required. 

 The Linked Notes feature is available for use with Word 2010, PowerPoint 2010, or 

Internet Explorer. 

 The Send to OneNote feature is available in any program on your computer from which 

you can print. 

 The capabilities to e-mail a note page, flag a note as a task for follow-up, and insert 

meeting details into your notes are designed for use with Outlook 2010. 

5. Which browsers are supported for the new OneNote Web App? 

Supported browsers include Windows Internet Explorer 7 or later for Windows, Safari 4 or 

later for Mac, and Firefox 3.5 or later for Windows, Mac, or Linux. 
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1. Are there free OneNote 2010 resources and training available from Microsoft? 

You can access numerous free, self-help resources on Office.com. Resources range from 

how-to training and demos to obtaining answers from your peers and independent experts 

–such as the Microsoft Most Valuable Professionals—in the Microsoft Office communities. 

2. Can I customize OneNote 2010 based on how I use the product? 

You can customize many aspects of OneNote 2010, including the following: 

 Set your preferences for a wide range of notebook and program behavior, ranging 

from how proofing and AutoCorrect features behave, to how notebook pages and 

the OneNote window appear, how save and backup is managed, and audio and 

video default settings.  Find all of these settings and many more in the OneNote 

Options dialog box. To do this, click the File tab to open Backstage view and then click 

Options. 

 Customize and create your own templates and tags. You can apply, customize, or 

save your own page templates and customize or create your own tags. To access 

available page templates or save your customized page as a template, click the arrow 

beside the New Page button and then click Page Templates. To customize tags, on the 

Home tab, in the Tags group, expand the Tags gallery and then click Customize Tags. 

 Customize tabs on the Ribbon or create your own tabs. Click the File tab to open 

Backstage view. Click Options and then click Customize Ribbon.  

 Add the commands you use frequently to the Quick Access Toolbar. Right-click a 

command on the Ribbon and then click Add to Quick Access Toolbar. 

 Set separate language settings for editing, Help, display and ScreenTips. On the 

Review tab, in the Language group, click Language and then click Language Preferences. 

 Set a default language for translation. On the Review tab, in the Language group, 

click Translate and then click Choose Translation Language. 

3. Can I access my notebooks when I am away from my primary computer? 

Using the new OneNote Web App, you can save your notebooks online and then access, 

view, search, edit, and share them from virtually any computer with an Internet connection.  

http://office.microsoft.com/
http://support.microsoft.com/mvp
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Additionally, using OneNote Mobile 2010, you can access and edit your notebooks from 

your Windows phone.10 

4. How do I access OneNote 2010 notebooks from a Web browser? 

Save your notebooks to a SharePoint 2010 site or Windows Live SkyDrive and then view and 

edit them using OneNote Web App.11 

5. What can I do with my OneNote 2010 notebooks in OneNote Web App? 

View your OneNote 2010 notebooks with high-fidelity, copy notebook content, and see who 

authored notebook content. Use many of the same formatting, editing, and file 

management features you use every day in OneNote 2010, including automatic spell check, 

AutoCorrect, tags, font and paragraph formatting, styles, the ability to insert tables and 

pictures, and access to previous page versions. You can also simultaneously edit a shared 

notebook with others using OneNote Web App and OneNote 2010. 

6. What can I do with my OneNote 2010 notebooks in OneNote Mobile 2010? 

OneNote Mobile 2010 provides an enhanced mobile version of OneNote specifically suited 

to your Windows phone. View, search, and do lightweight editing of your OneNote 2010 

notebooks on the go.  

1. Which editions of Microsoft Office 2010 will include OneNote 2010? 

OneNote 2010 2010 is available for purchase as part of all Office 2010 suites. To view a suite 

comparison for Microsoft Office 2010 so you can determine which suite is right for you, visit 

Office.com. 

2. Will OneNote 2010 be available for standalone purchase? 

Yes. 

                                                 

10
 Office Web Apps require either SharePoint Foundation 2010 or a free Windows Live account. Office Mobile 2010 will be available 

current with the release of Office 2010 and is not included in Office 2010 products or suites.  

11
 OneNote Web App via Windows Live will become available in the second half of calendar year 2010. 

http://office.com/
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3. Can I try OneNote 2010 before I buy it? 

Yes. Following general availability of Office 2010, you will be able to obtain a trial version. 

Visit Office.com for more information. 

4. Is there a Macintosh version of OneNote 2010? 

There is not a Mac version of OneNote 2010. However, you can find Notebook Layout View 

in Word for Mac 2008, which contains many features that are similar to OneNote, including 

the ability format and edit notes, create sections, and record audio notes in context while 

typing written notes. 

5. Is there a cost for using OneNote Web App? 

Office Web Apps are available in two ways: 

 Businesses that have a volume license agreement for Office 2010 have access to install 

Office Web Apps on SharePoint 2010 in their organization.  

 Individuals can access Office Web Apps on Windows Live, using a free Windows Live ID. 

6. When will Office Mobile 2010 be available and how do I get it? 

Office Mobile 201012 will be available concurrent with the release of Office 2010 and will be 

shipped with most smartphones running Windows Mobile 6.5 or later. 

1. What is a shared notebook? 

A shared notebook is a notebook that you store in a shared location (such as on a network 

drive or on a SharePoint or a Windows Live SkyDrive site), which can be edited 

simultaneously by multiple people.  

                                                 

12
 Office Mobile 2010 includes OneNote Mobile 2010, Word Mobile 2010, PowerPoint Mobile 2010, Excel Mobile 2010, Outlook 

Mobile 2010, and SharePoint Workspace Mobile 2010. 

http://office.com/
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2. Do I need to be on the same computer network with other editors to share notebooks 

in OneNote 2010? 

When you save your OneNote 2010 notebook to a SharePoint 2010 site or to Windows Live 

SkyDrive, you can share the notebook with people outside of your computer network who 

use OneNote 2010 or OneNote Web App.13 

3. Which Office 2010 applications enable co-authoring? 

Co-authoring (the ability to simultaneously edit the same file) is available in Word 2010, 

PowerPoint 2010, and OneNote 2010. This functionality is also available in OneNote Web 

App and Excel Web App. 

                                                 

13
 The ability to simultaneously edit OneNote notebooks that are stored in a Windows Live SkyDrive folder will become available in 

the second half of calendar year 2010. 
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 Office Mobile 2010 is not included in Office 2010 applications, suites, or Web Apps.  

 Office Mobile 2010 will be released on Windows phones (Windows Mobile 6.5 or above) 

by the general availability of Office 2010. 

Office Web Apps are online companions to Microsoft Office and require the following:   

 For businesses and institutions: Office Web Apps require SharePoint Foundation 2010. 

 For personal use: Office Web Apps require a free Windows Live ID. OneNote Web App 

and editing via Word Web App will become available on Windows Live in the second half 

of calendar year 2010. 

 Supported browsers for Office Web Apps include Windows Internet Explorer 7 or later 

for Windows, Safari 4 or later for Mac and Firefox 3.5 or later for Windows, Mac, or Linux. 

 Supported mobile viewers for Word, Excel, and PowerPoint Web Apps on SharePoint 

2010 include Internet Explorer on Windows Mobile 5 or later, Safari 4 on iPhone 3G or 

3GS, BlackBerry 4.x and later, Nokia S60, NetFront 3.4, 3.5 and later, Opera Mobile 8.65 

and later, and Openwave 6.2, 7.0 and later.  

Some links provided in this guide will not be available until after the general availability of 

Microsoft Office 2010. 
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This document is provided ―as-is.‖ Information and views expressed in this document, including 

URL and other Internet Web site references, may change without notice. You bear the risk of 

using it.  

Some examples depicted herein are provided for illustration only and are fictitious.  No real 

association or connection is intended or should be inferred.  

This document does not provide you with any legal rights to any intellectual property in any 

Microsoft product. You may copy and use this document for your internal, reference purposes. 

© 2010 Microsoft Corp. All rights reserved. 
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